Bug tracker updated

Here you may share your feedback on any of the online services we provide, or report technical issues that you may have encountered.

Moderator: Staff

User avatar
gorzuate
Developer
Posts: 2575
Joined: Thu Jun 17, 2004 3:03 am
Location: Hermosa Beach, CA
Contact:

Bug tracker updated

Postby gorzuate » Sun Mar 21, 2010 12:49 am

Our Mantis bug tracker has been upgraded to version 1.2.0 (latest stable). Let me know if you run into any issues.
Image
User avatar
Roots
Dictator
Posts: 8666
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Bug tracker updated

Postby Roots » Sun Mar 21, 2010 1:31 am

Can people register on the bug tracker again? Previously it wasn't sending out the confirmation e-mails that people needed to activate their tracker accounts. Looks great BTW, thanks for doing this!
Image
User avatar
gorzuate
Developer
Posts: 2575
Joined: Thu Jun 17, 2004 3:03 am
Location: Hermosa Beach, CA
Contact:

Re: Bug tracker updated

Postby gorzuate » Sun Mar 21, 2010 9:17 pm

Roots wrote:Can people register on the bug tracker again? Previously it wasn't sending out the confirmation e-mails that people needed to activate their tracker accounts. Looks great BTW, thanks for doing this!


Well barf :| Looks like the captcha image on the signup page isn't working. If you go there now, it'll look like it is working, because I copied over the PHP file that makes the captcha image from the old version. It looks like the only difference between those two files is that the new version adds an extra call to a string function related to UTF8. It looks like you can signup using the old captcha image file, but I haven't gotten a confirmation email yet. Upon installation I ran some checks and they all warned about bad things related to UTF8. Since everything else seemed okay I thought I could ignore them. Perhaps not, eh? I'll browse around on their forums, I think I saw a thread related to it. Their IRC channel wasn't much help at all. Anyway, until this is fixed, you will see a warning at the bottom of the login page saying the admin/ folder should be removed.
Image
User avatar
gorzuate
Developer
Posts: 2575
Joined: Thu Jun 17, 2004 3:03 am
Location: Hermosa Beach, CA
Contact:

Re: Bug tracker updated

Postby gorzuate » Sun Mar 21, 2010 11:30 pm

Well, I think this is our problem:
http://www.mantisbt.org/bugs/view.php?id=11549

If PHP can't change the include path, it won't be able to find the extra libraries it needs (for UTF8 and for creating the captcha image).
Image
User avatar
Bertram
Senior Member
Posts: 127
Joined: Fri Feb 26, 2010 10:08 am

Re: Bug tracker updated

Postby Bertram » Wed Mar 24, 2010 9:00 am

In the given bug, one said you should try the latest SVN version to fix that:
I suggest using a nightly build of MantisBT 1.3.x as this problem should be mostly resolved for now.

:arrow: Would it help?

Best regards.
User avatar
gorzuate
Developer
Posts: 2575
Joined: Thu Jun 17, 2004 3:03 am
Location: Hermosa Beach, CA
Contact:

Re: Bug tracker updated

Postby gorzuate » Thu Mar 25, 2010 6:04 am

Bertram wrote:In the given bug, one said you should try the latest SVN version to fix that:
I suggest using a nightly build of MantisBT 1.3.x as this problem should be mostly resolved for now.

:arrow: Would it help?

Best regards.


Probably. I'm a little reluctant to try something that hasn't been deemed stable, but right now it's worth checking out. :)
Image
User avatar
Bertram
Senior Member
Posts: 127
Joined: Fri Feb 26, 2010 10:08 am

Re: Bug tracker updated

Postby Bertram » Thu Mar 25, 2010 12:08 pm

Hi Gorzuate,

Probably. I'm a little reluctant to try something that hasn't been deemed stable, but right now it's worth checking out. :)


Is it possible to try a test version on a test account there? Or is there money involved in this option? :uhoh:

Regards,
User avatar
gorzuate
Developer
Posts: 2575
Joined: Thu Jun 17, 2004 3:03 am
Location: Hermosa Beach, CA
Contact:

Re: Bug tracker updated

Postby gorzuate » Thu Mar 25, 2010 6:01 pm

Yeah, I can setup a bug database for testing the 1.3 version; that's a good idea! No money involved :)
Image
User avatar
Roots
Dictator
Posts: 8666
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Bug tracker updated

Postby Roots » Fri Mar 26, 2010 12:31 am

I'm rather skeptical that such a major bug (no working registrations) would be present in a stable release. I am much more likely to suspect its something with our server or our configuration settings. I remember a few months back registration e-mails weren't working for the forums either. I forgot what I/we did (I think I was the one who fixed it, but not 100% sure). I think I went into the admin panel and changed some setting with our server address and then forum e-mails worked again.
Image
User avatar
Bertram
Senior Member
Posts: 127
Joined: Fri Feb 26, 2010 10:08 am

Re: Bug tracker updated

Postby Bertram » Fri Mar 26, 2010 9:08 am

Hi,

I'm rather sceptical that such a major bug (no working registrations) would be present in a stable release.

Well, I wouldn't be as surprised as you do, but indeed, it's also worth a try :)
User avatar
prophile
Senior Member
Posts: 324
Joined: Fri Jan 27, 2006 7:18 pm
Location: Chaldon, Surrey, UK
Contact:

Re: Bug tracker updated

Postby prophile » Fri Mar 26, 2010 8:23 pm

You might need to fiddle with the SMTP settings.
Alastair Lynn / Resident Whinger / Allacrost
User avatar
Bertram
Senior Member
Posts: 127
Joined: Fri Feb 26, 2010 10:08 am

Re: Bug tracker updated

Postby Bertram » Wed May 05, 2010 4:38 pm

and bump!

Any news upon this?

I still can't log in :sad: :ohnoes:

Best regards.

Return to “Online Services”

Who is online

Users browsing this forum: No registered users and 1 guest