Fix the website already!!!

Here you may share your feedback on any of the online services we provide, or report technical issues that you may have encountered.

Moderator: Staff

User avatar
Roots
Dictator
Posts: 8666
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Fix the website already!!!

Postby Roots » Sat Sep 27, 2008 4:52 pm

I didn't think it would be easy to transfer the theme over to the new site. I'm okay with the site looking the way you have it. Its not as pretty, but its functional. This is a major decision though that affects how we look publicly, so I want at least a couple other people to voice their opinions on the matter before we transfer the site over. A few other comments/concerns/requests while we're at this junction:


- On IRC last night you mentioned about a ton of registered but inactive users and should we delete them. Most of those inactive users are spam bots, so if they have a spam-ish name (like fjx48ly) then yes, delete them. Leave all inactive accounts with plausible sounding names (like jon98).

- Not all of the pages are transferred. If you try to view the FAQ from the "About" page or the application pages from the "Contribute" page, it takes you to the old theme on the old site.

- Is it possible to rename the page URls from "www.allacrost.org/node?q-20" or whatever to something human-sounding like "www.allacrost.org/about"?

- Can we have a page or link to where people can login or register on the site instead of having that only be available through the news story comments?

- The text of the logo in the upper left is not aligned with the background and needs to be fixed. It looks bad.

- Is it possible to have latest screenshot thumbnails under the secondary links text on the right hand pane? Having screenshots available right there on the front page was a feature we really wanted to have on our site because its usually one of the first things that players look for.


If any of those features are too difficult to implement, we don't have to have them. They would just be really nice to have. Oh, and the blog thing too if we can have a page for that, that would be awesome to start a team blog. :)
Image
User avatar
ElonNarai
Developer
Posts: 207
Joined: Sat Apr 19, 2008 2:43 pm
Location: Netherlands
Contact:

Re: Fix the website already!!!

Postby ElonNarai » Sat Sep 27, 2008 5:35 pm

Well, if we keep new.allacrost working I could try periodically try and improve the stylesheet. Priority one is to get the site working again.

Deleting users
As I said there is nothing against leaving them there. We can always clean up afterwards. Also some people make up the wierdest names :)

Old links
If the link was relative this wouldn't have been a problem, but they are absolute. It shouldn't really matter, when the site is transfered the links would refer to the correct location.

Renaming sites
yes, this can be done. I have the url-rename module installed, so if you login (add "/user/login" to the url) then you can simply rename it.

Login page
Just go to new.allacrost.org/user/login, I can create a link for but I assume that the only people who will really be using the site will be the staff. I will do it anyway since it's not that hard.

Logo
I made the logo from images on SVN but I had to combine it. Nice job noticing it, it took me a few seconds to realize what you meant.

Screenshots thumbs
I think that would require some developing (couldn't find anything for that in the drupal module database) but it doesn't seem that hard. I will think about on how we can approach that.
Documenter and coder
Image
User avatar
Roots
Dictator
Posts: 8666
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Fix the website already!!!

Postby Roots » Sat Sep 27, 2008 10:05 pm

Also can we get a captcha system so that we don't have so many spam registrations on the site? I'd also like to use it so that people can post comments as guests again. I had to disable that feature because we were getting an enormous amount of anonymous spam comments in the posts.
Image
User avatar
Roots
Dictator
Posts: 8666
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Fix the website already!!!

Postby Roots » Sat Sep 27, 2008 11:48 pm

Actually scratch the "waiting on people to voice their opinions on the website". If no one protests the decision by tomorrow, I say just go ahead and make the switch. Too many people on this team are disinterested in these sorts of matters right now and there's no point in waiting on feedback that likely won't come.


Also can you remove the "# reads" for each news article? They are pointless and inaccurate (you have to click the news article title to "read" it, even though the text is all there on the front page).
Image
User avatar
gorzuate
Developer
Posts: 2575
Joined: Thu Jun 17, 2004 3:03 am
Location: Hermosa Beach, CA
Contact:

Re: Fix the website already!!!

Postby gorzuate » Sun Sep 28, 2008 4:00 am

That's too bad about the old theme. I really liked it a lot. But if this new site improves administration, then I guess it's a hit we'll have to take.
Image
User avatar
ElonNarai
Developer
Posts: 207
Joined: Sat Apr 19, 2008 2:43 pm
Location: Netherlands
Contact:

Re: Fix the website already!!!

Postby ElonNarai » Sun Sep 28, 2008 3:10 pm

Ok, I have updated the site and it has a working teamblog


For more information see: http://allacrost.sourceforge.net/wiki/i ... nistration
Documenter and coder
Image
User avatar
Roots
Dictator
Posts: 8666
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Fix the website already!!!

Postby Roots » Sun Oct 12, 2008 5:25 pm

I fixed the problem with the application form on the site and I was able to successfully apply. There's one slight problem though. After submitting the application it comes back with the e-mail successfully sent page, but the page layout is from the previous site design, not the current one. Elon, do you think you can look into that? The script file which processes the application and brings me to this page is: http://www.allacrost.org/rapid_form_application.cgi
Image
User avatar
ElonNarai
Developer
Posts: 207
Joined: Sat Apr 19, 2008 2:43 pm
Location: Netherlands
Contact:

Re: Fix the website already!!!

Postby ElonNarai » Mon Oct 13, 2008 2:49 pm

I will look in to it.
Documenter and coder
Image
User avatar
ElonNarai
Developer
Posts: 207
Joined: Sat Apr 19, 2008 2:43 pm
Location: Netherlands
Contact:

Re: Fix the website already!!!

Postby ElonNarai » Mon Oct 13, 2008 3:01 pm

And fixed ^_^
Documenter and coder
Image
User avatar
Roots
Dictator
Posts: 8666
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Fix the website already!!!

Postby Roots » Sat Nov 01, 2008 9:33 pm

I fixed the script error on the application script. The problem was that it was looking for a file named applythanks.php, but for some reason that file got renamed to _applythanks.php. So now we won't get any more confused applicants.


There is one problem with it still (that I wont' fix myself). The applythanks page takes the user back to the old website layout. Something we should fix eventually, but its not high priority.
Image
User avatar
ElonNarai
Developer
Posts: 207
Joined: Sat Apr 19, 2008 2:43 pm
Location: Netherlands
Contact:

Re: Fix the website already!!!

Postby ElonNarai » Sun Nov 02, 2008 10:02 am

The reason that I renamed it was because the site took took over that page. (made a thank you page in drupal, which would be visible when applythanks.php was requested)

Since the page only contained

Code: Select all

   Thank you for contacting us with your application. We will get back to you soon with more information and questions.
   <br><br>
   <b>The Allacrost Team

And no functional code so there shouldn't be a problem.

So why were the applicants confused? It worked when I tested it.
Documenter and coder
Image
User avatar
Roots
Dictator
Posts: 8666
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Fix the website already!!!

Postby Roots » Sun Nov 02, 2008 3:41 pm

Because when that php file wasn't found, instead the users were taken to a blank page that said "Script error: blah blah blah" and they thought that their application didn't get through. So we had some people re-send their application a number of times over.
Image
User avatar
ElonNarai
Developer
Posts: 207
Joined: Sat Apr 19, 2008 2:43 pm
Location: Netherlands
Contact:

Re: Fix the website already!!!

Postby ElonNarai » Mon Nov 03, 2008 3:57 pm

Wierd, drupal should have caught that.
Documenter and coder
Image
User avatar
Roots
Dictator
Posts: 8666
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Fix the website already!!!

Postby Roots » Mon Nov 03, 2008 4:00 pm

Well if you read the CGI script, if it doesn't find that file that error message is exactly what it prints. Even though the message was sent successfully.
Image

Return to “Online Services”

Who is online

Users browsing this forum: No registered users and 2 guests