Unable to post to forums because you are blacklisted [FIXED]

Here you may share your feedback on any of the online services we provide, or report technical issues that you may have encountered.

Moderator: Staff

Post Reply
User avatar
Roots
Dictator
Posts: 8668
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Unable to post to forums because you are blacklisted [FIXED]

Post by Roots » Thu Jan 08, 2015 4:23 am

Just an FYI, earlier today I found myself unable to post anything to the forums. An error message popped up saying that the domain for my registered e-mail address (@allacrost.org) was blacklisted. I was thoroughly confused by this, and discovered that the same error was being printed for @gmail.com addresses. I did some investigation and it turns out that one of the sites (http://www.ahbl.org/) that we check against for blacklisted spammers decided to, for some reason, enable all queries to return positive responses. In other words, anytime we asked that site "is this person a spammer?" it would return with a yes answer.

I've removed the site in question from our list of blacklisting sites to fix this problem. May need to add it back again later if they provide an updated URL for where we should run our blacklist queries. I doubt this affected anyone much, but wanted to note it here anyway in case anyone was confused as to why the forums were telling people that they were a spammer if they tried to post in the last 24 hours.
Image
User avatar
Roots
Dictator
Posts: 8668
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Unable to post to forums because you are blacklisted [FI

Post by Roots » Sat Jan 31, 2015 5:21 am

So apparently this wasn't completely fixed. Forum registration was still using this bad site and returning false positives for everyone who tried to register on the forums in the last three weeks. That explains why we haven't seen any new registrations and no new contributors. :uhoh: Registrations should be working again now.
Image
Post Reply