Complete audio visual failure

For those having trouble installing/running the game or to report a bug

Moderator: Staff

jjd
Newbie
Posts: 5
Joined: Sat Jun 18, 2011 1:05 am

Complete audio visual failure

Postby jjd » Sat Jun 18, 2011 1:52 am

Hi,

I'm interested in helping with the project so I downloaded and built (on ubuntu 11.04) the repository from sourceforge. Initially the start screen ran (audio was working) and I changed the key bindings. But when I selected 'new game' I lost the signal to my monitor and the screen was totally unresponsive, so I had to do a forced shutdown. Now if I start I get a blank window (no start screen) and the following errors are dumped to the console:

ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
Segmentation fault


PCI devices:

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0)
00:07.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 3)
00:11.0 SATA controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode]
00:12.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB7x0 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB7x0 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.1 IDE interface: ATI Technologies Inc SB7x0/SB8x0/SB9x0 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:00.0 VGA compatible controller: ATI Technologies Inc Cypress [Radeon HD 5800 Series]
01:00.1 Audio device: ATI Technologies Inc Cypress HDMI Audio [Radeon HD 5800 Series]
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 20)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)


CPU specs:

Architecture: i686
CPU op-mode(s): 64-bit
CPU(s): 4
Thread(s) per core: 1
Core(s) per socket: 4
CPU socket(s): 1
Vendor ID: AuthenticAMD
CPU family: 16
Model: 4
Stepping: 3
CPU MHz: 800.000
Virtualization: AMD-V
L1d cache: 64K
L1i cache: 64K
L2 cache: 512K
L3 cache: 6144K

I'll see if I can figure out more, but I thought I'd post the data I have in case anyone has experience with this.

-Josh
User avatar
Roots
Dictator
Posts: 8665
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Complete audio visual failure

Postby Roots » Sat Jun 18, 2011 2:09 am

Sorry to hear about the trouble you're having. I also develop on Ubuntu 11.04 so I know that the official Ubuntu packages are functional. I get some messages printed too whenever I startup (messages that are not printed directly by the application). They are below:

Code: Select all

./allacrost
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started


One thing you can try to do is run Allacrost with the arguments "-d all". This will cause debug statements from all subsystems in the code to print any messages, warnings, or errors.



What audio system do you have running on your system? I have PulseAudio i believe. I will say that I'm suspicious about the ATI drivers, because we've had someone else report crashing with the game that was due to the ATI drivers, not the fault of our code. If you can get a stack trace when it crashes and post it here, that would be very helpful.
Image
jjd
Newbie
Posts: 5
Joined: Sat Jun 18, 2011 1:05 am

Re: Complete audio visual failure

Postby jjd » Sat Jun 18, 2011 3:37 am

Roots wrote:Sorry to hear about the trouble you're having. I also develop on Ubuntu 11.04 so I know that the official Ubuntu packages are functional. I get some messages printed too whenever I startup (messages that are not printed directly by the application). They are below:

Code: Select all

./allacrost
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started


One thing you can try to do is run Allacrost with the arguments "-d all". This will cause debug statements from all subsystems in the code to print any messages, warnings, or errors.



What audio system do you have running on your system? I have PulseAudio i believe. I will say that I'm suspicious about the ATI drivers, because we've had someone else report crashing with the game that was due to the ATI drivers, not the fault of our code. If you can get a stack trace when it crashes and post it here, that would be very helpful.


I spoke with a friend at work about the problem and he also suggested that it could be the ATI drivers. I ran gdb allocrost and when I escape (which triggers the segv) it stops in /usr/lib/fglrx/dri/fglrx_dri.so, which I believe is the ATI driver. So I will try purging the ATI driver and replace it with the open source version to see if that helps.

-Josh
User avatar
Roots
Dictator
Posts: 8665
Joined: Wed Jun 16, 2004 6:07 pm
Location: Austin TX
Contact:

Re: Complete audio visual failure

Postby Roots » Sat Jun 18, 2011 3:52 am

Yeah, it sucks because there's nothing that we can do about this on our end. I stopped buying ATI products several years ago because their Linux drivers were horrible, and I'm sad to see that not much has changed since. :( Keep us updated on this issue.
Image
jjd
Newbie
Posts: 5
Joined: Sat Jun 18, 2011 1:05 am

Re: Complete audio visual failure

Postby jjd » Sat Jun 18, 2011 1:18 pm

Roots wrote:Yeah, it sucks because there's nothing that we can do about this on our end. I stopped buying ATI products several years ago because their Linux drivers were horrible, and I'm sad to see that not much has changed since. :( Keep us updated on this issue.


Well, I tried using the open source ATI drivers but that did not help so I have installed the source on my older box and it seemed to run fine. However, I did get some of the same messages dumped to the console:

bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started

Nonetheless, I can at least play the game :-)

-Josh
rujasu
Developer
Posts: 758
Joined: Sun Feb 25, 2007 5:40 am
Location: Maryland, USA

Re: Complete audio visual failure

Postby rujasu » Sat Jun 18, 2011 4:17 pm

I don't remember the ATI drivers ever crashing the game, though I did have some problems with the editor on an old integrated ATI chip. Regardless, that shouldn't be a problem for the game itself.

Are you actually getting proper sound? Is there any skipping or distortion? If not, don't worry about those error messages. They show up because OpenAL is trying to connect to every possible sound system you could have, including ALSA, OSS, Pulse, and whatever else there is. There's a way you can manually configure OpenAL to check only a certain sound system, so if you're running PulseAudio it would only try the Pulse driver. If you're having problems with the audio, let us know, and I'll try to point you in the right direction there.
jjd
Newbie
Posts: 5
Joined: Sat Jun 18, 2011 1:05 am

Re: Complete audio visual failure

Postby jjd » Sun Jun 19, 2011 3:16 pm

rujasu wrote:I don't remember the ATI drivers ever crashing the game, though I did have some problems with the editor on an old integrated ATI chip. Regardless, that shouldn't be a problem for the game itself.

Are you actually getting proper sound? Is there any skipping or distortion? If not, don't worry about those error messages. They show up because OpenAL is trying to connect to every possible sound system you could have, including ALSA, OSS, Pulse, and whatever else there is. There's a way you can manually configure OpenAL to check only a certain sound system, so if you're running PulseAudio it would only try the Pulse driver. If you're having problems with the audio, let us know, and I'll try to point you in the right direction there.


Initially I was getting both audio and video working perfectly. The start menu came up and the intro music was playing. When I started a new game both the audio and video cut completely. Each time I have restart the game I get neither audio or video -- not even the start screen. On my older system I have absolutely no trouble running the game (audio and video are perfect -- nVidia card incidentally).

-Josh
rujasu
Developer
Posts: 758
Joined: Sun Feb 25, 2007 5:40 am
Location: Maryland, USA

Re: Complete audio visual failure

Postby rujasu » Sun Jun 19, 2011 4:26 pm

What happens if you switch from libgl1-mesa-glx to libgl1-mesa-swx11? (Make sure to disable any compositing first, if you have that.) That switches you to the software rasterizer, which won't run fast enough to properly use the game, or most other OpenGL applications, but doing the switch temporarily can be useful to isolate the driver/chipset as being the issue.
jjd
Newbie
Posts: 5
Joined: Sat Jun 18, 2011 1:05 am

Re: Complete audio visual failure

Postby jjd » Sun Jun 19, 2011 4:38 pm

rujasu wrote:What happens if you switch from libgl1-mesa-glx to libgl1-mesa-swx11? (Make sure to disable any compositing first, if you have that.) That switches you to the software rasterizer, which won't run fast enough to properly use the game, or most other OpenGL applications, but doing the switch temporarily can be useful to isolate the driver/chipset as being the issue.


I switched to libgl1-mesa-swx11 but I got the same result. I'm not sure what you mean by compositing, but if you can tell me what I need to do to disable it, I'll let you know what happens.

-Josh
q4a
Newbie
Posts: 1
Joined: Sun Jul 31, 2011 7:55 am

Re: Complete audio visual failure

Postby q4a » Sun Jul 31, 2011 8:15 am

Roots wrote:

Code: Select all

./allacrost
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
I have the same errors on my Lubuntu 11.04 (Intel Pentium 4, 3 Ghz, 3 Gb Ram, Radeon X800 GTO) and game doesn't start, but after switch from libgl1-mesa-glx to libgl1-mesa-swx11 I still getting the error messages, but game works almost fine: sound a bit slow, but i have the same problem on Windows XP.
PS i tested development release 20110717.
PSS thanks for the game!!

Return to “Technical Issues”

Who is online

Users browsing this forum: No registered users and 3 guests