Hello, we apologize but forum registrations are non-functional at this time. This issue should be fixed around mid-December. Until then, please stop by our Discord channel if you'd like to get in touch with the team. Thanks!

Segmentation fault [SOLVED]

For those having trouble installing/running the game or to report a bug

Moderator: Staff

Post Reply
sharpe95
Newbie
Posts: 4
Joined: Fri Dec 28, 2007 4:28 pm

Segmentation fault [SOLVED]

Post by sharpe95 » Fri Dec 28, 2007 4:30 pm

After I run allacrost on the command line, there's a segmentation fault and the core is dumped. I'm wondering if anybody could help? I'm running Ubuntu 7.10 Gutsy.

EDIT: I installed libluabind0 and g++-4.2 with Synaptic Package Manager. Still, seg fault.
rujasu
Developer
Posts: 758
Joined: Sat Feb 24, 2007 10:40 pm
Location: Maryland, USA

Post by rujasu » Fri Dec 28, 2007 8:04 pm

Are you using a debian package through synaptic, or are you compiling Allacrost from source? Also, what is the version number for the libluabind0 package?
sharpe95
Newbie
Posts: 4
Joined: Fri Dec 28, 2007 4:28 pm

Post by sharpe95 » Sat Dec 29, 2007 9:10 am

It's all from debian packages. I didn't compile allacrost.

The version of libluabind0 is 0.7dfsg-1.

Thanks for helping :)

EDIT: In case you need to know, my lua version is 5.0.3-2build1.
ettin
Junior Member
Posts: 45
Joined: Thu Aug 31, 2006 3:23 pm

Post by ettin » Sat Dec 29, 2007 2:41 pm

sharpe95 wrote:It's all from debian packages. I didn't compile allacrost.

The version of libluabind0 is 0.7dfsg-1.

Thanks for helping :)

EDIT: In case you need to know, my lua version is 5.0.3-2build1.
Are you using the Etch backports? Those packages worked with previous versions of Ubuntu, but not with Gutsy (btw, can someone please update the website?). Instead, you should probably use the following .debs: allacrost-data and allacrost-demo.
sharpe95
Newbie
Posts: 4
Joined: Fri Dec 28, 2007 4:28 pm

Post by sharpe95 » Sun Dec 30, 2007 10:19 am

The game works now, thanks!
Post Reply