Hello, we apologize but forum registrations are non-functional at this time. This issue should be fixed around mid-December. Until then, please stop by our Discord channel if you'd like to get in touch with the team. Thanks!

libx6 and demo2 on ubuntu Feisty

For those having trouble installing/running the game or to report a bug

Moderator: Staff

Post Reply
MrDowntempo
Newbie
Posts: 5
Joined: Mon May 07, 2007 3:06 am

libx6 and demo2 on ubuntu Feisty

Post by MrDowntempo » Mon Jun 11, 2007 9:02 am

I can't install the demo. I get this error:
allacrost-demo:
Depends: libc6 (>=2.5-5) but 2.5-0ubuntu14 is to be installed
Depends: libgcc1 (>=1:4.2-20070516) but 1:4.1.2-0ubuntu4 is to be installed
Depends: libluabind0 but it is not installable
Depends: libstdc++6 (>=4.2-20070516) but 4.1.2-0ubuntu4 is to be installed
User avatar
Roots
Dictator
Posts: 8669
Joined: Wed Jun 16, 2004 12:07 pm
Location: Austin TX
Contact:

Post by Roots » Mon Jun 11, 2007 12:06 pm

Are you compiling from source, or using a .deb package?
Image
ettin
Junior Member
Posts: 45
Joined: Thu Aug 31, 2006 3:23 pm

Post by ettin » Mon Jun 11, 2007 1:27 pm

Roots wrote:Are you compiling from source, or using a .deb package?
It looks like he is trying to install the .deb.

There is more than one problem though. On the one hand, it looks like luabind isn't available in Ubuntu; on the other, the package is built for Debian unstable, which has a newer libc than Ubuntu feisty. So, in order to fix this, both allacrost and luabind have to be rebuilt for Ubuntu's libc.

EDIT. I'll take a look at it, but I have little time at the moment and no Ubuntu box around... I'm not sure when it will be ready.
MrDowntempo
Newbie
Posts: 5
Joined: Mon May 07, 2007 3:06 am

Post by MrDowntempo » Mon Jun 11, 2007 5:38 pm

Yes, its the .deb of course. I figured it would work since it says so on the download page (might wanna alter that). I tried compiling next, but libluabind isn't offered in the ubuntu repos so it fails at ./configure.
User avatar
Roots
Dictator
Posts: 8669
Joined: Wed Jun 16, 2004 12:07 pm
Location: Austin TX
Contact:

Post by Roots » Mon Jun 11, 2007 5:42 pm

There's a thread somewhere on the forums that give instructions for how to install Luabind on Debian/Ubuntu. I wrote it because I had to compile that lib from source to get Allacrost to work on my Debian and Ubuntu machines.
Image
ettin
Junior Member
Posts: 45
Joined: Thu Aug 31, 2006 3:23 pm

Post by ettin » Tue Jun 12, 2007 2:56 am

ettin wrote:EDIT. I'll take a look at it, but I have little time at the moment and no Ubuntu box around... I'm not sure when it will be ready.
OK, I backported luabind and allacrost to Debian etch... I have not really checked all the dependencies and I'm not sure if it will work on Ubuntu or not, but feel free to try it out:

Code: Select all

deb http://debian.ettin.org/allacrost etch-backports main
el mariachi
Newbie
Posts: 6
Joined: Tue Jun 12, 2007 5:59 am

Post by el mariachi » Tue Jun 12, 2007 7:51 am

Code: Select all

allacrost-demo:
  Depends: libc6 (>=2.5-5) but 2.5-0ubuntu14 is to be installed
  Depends: libgcc1 (>=1:4.2-20070516) but 1:4.1.2-0ubuntu4 is to be installed
  Depends: libstdc++6 (>=4.2-20070516) but 4.1.2-0ubuntu4 is to be installed
it still outputs this...
ettin
Junior Member
Posts: 45
Joined: Thu Aug 31, 2006 3:23 pm

Post by ettin » Tue Jun 12, 2007 9:23 am

el mariachi wrote:

Code: Select all

allacrost-demo:
  Depends: libc6 (>=2.5-5) but 2.5-0ubuntu14 is to be installed
  Depends: libgcc1 (>=1:4.2-20070516) but 1:4.1.2-0ubuntu4 is to be installed
  Depends: libstdc++6 (>=4.2-20070516) but 4.1.2-0ubuntu4 is to be installed
it still outputs this...
You are installing the wrong deb. 0.0.0+svn858.dfsg-1~bpo.1 Depends on:

Code: Select all

libc6 (>= 2.3.6-6)
libgcc1 (>= 1:4.1.1-12)
libstdc++6 (>= 4.1.1-12)
el mariachi
Newbie
Posts: 6
Joined: Tue Jun 12, 2007 5:59 am

Post by el mariachi » Tue Jun 12, 2007 10:06 am

I'm trying to get it from the repositories, how can it be the wrong version? :eyebrow:
ettin
Junior Member
Posts: 45
Joined: Thu Aug 31, 2006 3:23 pm

Post by ettin » Tue Jun 12, 2007 10:11 am

el mariachi wrote:I'm trying to get it from the repositories, how can it be the wrong version? :eyebrow:
Then you are using the wrong repository ;)
http://allacrost.sourceforge.net/wiki/i ... ons#Debian
el mariachi
Newbie
Posts: 6
Joined: Tue Jun 12, 2007 5:59 am

Post by el mariachi » Tue Jun 12, 2007 10:33 am

did everything like it says (using etch repository) still a no go :(
ettin
Junior Member
Posts: 45
Joined: Thu Aug 31, 2006 3:23 pm

Post by ettin » Tue Jun 12, 2007 10:42 am

el mariachi wrote:did everything like it says (using etch repository) still a no go :(
Can you tell me what's the problem now? Still the same? Did you remove the other entry in the sources.list file?
el mariachi
Newbie
Posts: 6
Joined: Tue Jun 12, 2007 5:59 am

Post by el mariachi » Tue Jun 12, 2007 11:42 am

yes, it still tells me that those packages can't be installed.

the only third-party reposito I've got is this

Code: Select all

deb http://debian.ettin.org/allacrost
el mariachi
Newbie
Posts: 6
Joined: Tue Jun 12, 2007 5:59 am

Post by el mariachi » Thu Jun 21, 2007 5:05 pm

no developments on this issue?
User avatar
Roots
Dictator
Posts: 8669
Joined: Wed Jun 16, 2004 12:07 pm
Location: Austin TX
Contact:

Post by Roots » Thu Jun 21, 2007 5:07 pm

I've heard that Ubuntu Fiesty works fine with the Debian stable packages:

http://allacrost.sourceforge.net/wiki/i ... ons#Debian


Haven't had any confirmations of that package failing for Ubuntu yet. So just make sure you install from stable instead of unstable and it should work. :approve:
Image
Post Reply