Page 1 of 1

Installing in Ubuntu 7.04

Posted: Mon May 14, 2007 5:59 pm
by Nehvrook
Hi, I tried to install the game by compiling it myself but got stuck when I couldn't figure out how to make the OpenGL library work during compiling. In the Ubuntu forums I was told that there is an apt package available.
The thing is I'm new to Linux and having a bit trouble with /etc/apt/sources.list in that it always tells me I don't have permission to edit this file. But I need to to be able to install this apt package.
I had the same problem with some codecs for playing video a while ago and someone told me to do this to fix it:
In a terminal
wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add -
In a terminal
sudo wget http://medibuntu.sos-sts.com/sources.list.d/feisty.list -O /etc/apt/sources.list.d/medibuntu.list
This will add medibuntu sources
I managed to do that fine but I don't really understand what it did :(
So I was wondering if anyone here could tell me what I need to do to get this game's sources added and I think I can figure it out from there.
Thanks :)

Posted: Fri May 18, 2007 2:39 am
by gorzuate
Sorry about the slow response :ohnoes:

Try this.

Hopefully that will work.

Now, I'll try and explain what you asked about, but since I don't use Ubuntu, I may be a little off.

You probably don't have permission to edit /etc/apt/sources.list since only root can do that. In order for you to get root permissions, and hence edit the file, you can do 1 of 2 things:
1) su
This will log you in as the super-user, i.e. root, so you can edit the file.

2) sudo <insert-favorite-text-editor-here> /etc/apt/sources.list
This will fire up an editor with the sources.list file and with root permissions.

I believe, and this is where it gets iffy, that sources.list is used to tell the repository server what files you want to install, and/or where in fact a repository server is located on the web, so that apt-get can properly download and install the program.

Again, sorry about the slow response time. :angel:

Posted: Tue Jun 12, 2007 6:03 am
by el mariachi
when i try to download the game files (both from synaptic and apt-get) I get an error saying there are unresolved dependencies.

Code: Select all

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  allacrost-demo: Depends: libc6 (>= 2.5-5) but 2.5-0ubuntu14 is to be installed
                  Depends: libgcc1 (>= 1:4.2-20070516) but 1:4.1.2-0ubuntu4 is to be installed
                  Depends: libluabind0 but it is not installable
                  Depends: libstdc++6 (>= 4.2-20070516) but 4.1.2-0ubuntu4 is to be installed
E: Broken packages

Posted: Tue Jun 12, 2007 6:43 am
by ettin
el mariachi wrote:when i try to download the game files (both from synaptic and apt-get) I get an error saying there are unresolved dependencies.
http://www.allacrost.org/forum/viewtopic.php?t=1734